PDA

View Full Version : New AikiWeb Forums Software


Please visit our sponsor:
 

AikiWeb Sponsored Links - Place your Aikido link here for only $10!


akiy
04-19-2004, 01:55 AM
Hi everyone,

I just spent the last several hours upgrading the software underlying the AikiWeb Forums to the latest and greatest version.

As such, you may very well find that some things are different -- hopefully in a good way!

There are a lot of great, new features that might not be too evident at first glance. I hope to have some time in the next couple of days to outline some of the newest features of the new software.

Until then, please let me know if you come across anything that looks odd, any errors, or anything that you would like clarified.

Here's to hoping that the new software makes your experience participating here in the AikiWeb Forums a more enjoyable experience!

-- Jun

DanielR
04-19-2004, 08:21 AM
Hi Jun,

Thanks for this - especially the fact posts were given a wider space, makes it easier to read the longer ones.

There's a couple of minor glitches I've noticed so far:

- I tried to log out a couple of times, and both times was forwarded to a page that said "An error occurred while attempting to log you out. Click here to log out."

- I have "invisible mode" selected in my Control Panel, but am still showing in the list of active users (albeit with an asterisk)

Thanks again,

Yann Golanski
04-19-2004, 08:37 AM
Biggest problem I see: No spelling checker in quick reply. Please, can we have it back so I can pretend I can write English?... Thanks.

Apart from that, I've seen no problems so far -- well, apart from the "no new post" when I launch Firefox every morning but that maybe a firefox problem.

I really like the new design.

Many thanks Jun!

akiy
04-19-2004, 08:56 AM
Hi Yann,
Biggest problem I see: No spelling checker in quick reply. Please, can we have it back so I can pretend I can write English?... Thanks.
Yup. It's just a feature that I need to re-incorporate that I didn't quite feel like getting to last night at 2am. I should have it re-integrated today or real soon otherwise...
Apart from that, I've seen no problems so far -- well, apart from the "no new post" when I launch Firefox every morning but that maybe a firefox problem.
Odd; I use Firefox as well and haven't seen that problem.

You might want to try clearing your cookies (either all of them or selectively deleting all www.aikiweb.com/aikiweb.com cookies through Tools/Options/Privacy/Cookies) and seeing how it goes...
I really like the new design.
Thanks!

-- Jun

akiy
04-19-2004, 08:59 AM
Hi Daniel,
Thanks for this - especially the fact posts were given a wider space, makes it easier to read the longer ones.
You're welcome! That's now a user-selectable option via the User Control Panel in "Edit Options." It may take a time or two setting/resetting it or clearing your cookies...

- I tried to log out a couple of times, and both times was forwarded to a page that said "An error occurred while attempting to log you out. Click here to log out."
I think that's also a cookies problem as well. I'll see about having a solution up soon (about clearing your cookies).
- I have "invisible mode" selected in my Control Panel, but am still showing in the list of active users (albeit with an asterisk)
If you see an asterisk by your name, it's only an indicator that the person with said asterik (yourself) is invisible but you yourself can see that person due to permissions. So, in other words, you'll be able to see yourself but others will not be able to see you!

-- Jun

Yann Golanski
04-19-2004, 09:01 AM
Hi Yann,

Yup. It's just a feature that I need to re-incorporate that I didn't quite feel like getting to last night at 2am. I should have it re-integrated today or real soon otherwise...


That's beyond the call of duty... NO ONE should be doing admin work past 21:00!


Odd; I use Firefox as well and haven't seen that problem.

You might want to try clearing your cookies (either all of them or selectively deleting all www.aikiweb.com/aikiweb.com cookies through Tools/Options/Privacy/Cookies) and seeing how it goes...


Yeah, I suspect it's some cookie errors. I've set it up to bin all cookies as I exit the browser -- means that I have to login everyday but...

Will let you know.

SeiserL
04-19-2004, 09:05 AM
You are just too good to us. Compliments and appreciation. Thank you.

DanielR
04-19-2004, 09:14 AM
Jun, thanks for the clarifications.
Heh, sysadmin work past 9pm doesn't surprise me; what does, however, is the fact that Jun started this thread at 3am EST and responded to the first feedbacks at 10AM EST. That's less than 7 hours of sleep! Now that is definitely beyond the call of duty... :D

akiy
04-19-2004, 09:19 AM
You are just too good to us. Compliments and appreciation. Thank you.
Thanks, Lynn. I appreciate your thoughts.
Heh, sysadmin work past 9pm doesn't surprise me; what does, however, is the fact that Jun started this thread at 3am EST and responded to the first feedbacks at 10AM EST. That's less than 7 hours of sleep! Now that is definitely beyond the call of duty... :D
Heh -- I still have to get to work, you know...

-- Jun

akiy
04-19-2004, 09:47 AM
- I tried to log out a couple of times, and both times was forwarded to a page that said "An error occurred while attempting to log you out. Click here to log out."
I believe I have fixed this issue. Let me know if it crops up anywhere again...

-- Jun

DanielR
04-19-2004, 10:13 AM
Thanks Jun, it works fine now.
Another minor thing - I accessed the Calendar now, and it seems that the following image is unaccessible (shows as that red X in IE):
http://www.aikiweb.com/forums/images/misc/birthday_small.gif

akiy
04-19-2004, 10:21 AM
Another minor thing - I accessed the Calendar now, and it seems that the following image is unaccessible (shows as that red X in IE):
http://www.aikiweb.com/forums/images/misc/birthday_small.gif
Fixed. I'm glad the logging out thing seems to be fixed too, now.

-- Jun

akiy
04-19-2004, 12:33 PM
Biggest problem I see: No spelling checker in quick reply. Please, can we have it back so I can pretend I can write English?...
I have re-integrated the spelling checker into the quick reply and the new thread pages...

-- Jun

Ron Tisdale
04-19-2004, 01:50 PM
Great job Jun! The wide format caught me by surprise this morning! Great way to wake me up...

Ron :)

Steven
04-19-2004, 02:50 PM
Very nice Jun. Thanks!

Steven
04-19-2004, 03:15 PM
Jun,

After further review, and maybe I'm just not seeing it, but what happened to the option to mark all forums as read? Also, refreshing is a bit slow, but i'm sure that's due to all the folks catching up on their reading.

Still nice though ...

Steven

akiy
04-19-2004, 03:23 PM
After further review, and maybe I'm just not seeing it, but what happened to the option to mark all forums as read?
You'll find that option under "Quick Links" near the top right of the page.
Also, refreshing is a bit slow, but i'm sure that's due to all the folks catching up on their reading.
There's also some CPU intensive maintenance going on in the background right now...

I'm hoping to upgrade the server sometime in the near future... Hopefully, that'll help speed things up, too...

-- Jun

Doka
04-19-2004, 03:51 PM
Maybe I'm not seeing it, but where has the AikiWall gone?

akiy
04-19-2004, 03:57 PM
Hi Mark,
Maybe I'm not seeing it, but where has the AikiWall gone?
You should be able to find it as the third item under the "What's Going On?" box near the bottom of the forum home page.

-- Jun

Doka
04-19-2004, 04:01 PM
Cheers Jun

I always used to navigate to it at the top of a thread page. Now I know I can have a look and see the fast (?) :) flowing posts there!

Ta!

Erik
04-19-2004, 04:44 PM
Jun, Opera 7 in 800x600 produces some minor horizontal scrolling when viewing threads (I checked multiple threads). It's not doing it on this page (reply page), however. I checked it on Netscape 7.x where it was fine and I assume it's fine on Internet Explorer.

akiy
04-20-2004, 12:01 PM
Jun, Opera 7 in 800x600 produces some minor horizontal scrolling when viewing threads (I checked multiple threads). It's not doing it on this page (reply page), however. I checked it on Netscape 7.x where it was fine and I assume it's fine on Internet Explorer.
Thanks, Erik. I'll take a look through Opera. I appreciate your feedback.

I think I just fixed a small bug that should speed things up a bit...

-- Jun

Kent Enfield
04-20-2004, 03:44 PM
Okay, banner adds at the top of the page are one thing, but in the middle of threads?

Yuck.

Don_Modesto
04-20-2004, 04:27 PM
Thanks, Jun.

Chuck Clark
04-20-2004, 06:27 PM
Jun, It looks different for sure, but so far everything works for me. Thanks for your generosity and hard work.

Bronson
04-21-2004, 10:16 AM
Okay, banner adds at the top of the page are one thing, but in the middle of threads?

I would agree but at the same time Jun offers this site and all the work he puts into it for free so I guess I can deal with the ads.

Bronson

akiy
04-21-2004, 11:01 AM
I would agree but at the same time Jun offers this site and all the work he puts into it for free so I guess I can deal with the ads.
Thank you, Bronson. I started offering the "sponsored links" to try to offset some of the costs of running the server. I can't say it's even come close to covering even just the material costs (not to count the numerous hours I spend upkeeping the site) incurred over the years, but I'm hoping, perhaps, one of these days...

-- Jun

Don_Modesto
04-21-2004, 01:05 PM
Btw, sorry if I've just missed this, AJ has a nice feature which presents all the recent posts. e-Budo makes you sign in for it, but it goes back further than just today.

Is there anything like that here? (There used to be, but I don't see it now.

Thanks.

akiy
04-21-2004, 01:24 PM
Hi Don,
Btw, sorry if I've just missed this, AJ has a nice feature which presents all the recent posts. e-Budo makes you sign in for it, but it goes back further than just today.

Is there anything like that here? (There used to be, but I don't see it now.
Yup. Click on the "New Posts" link near the top.

There's also a drop-down for "Active Topics" which gives you the option of searching for active topics within the past X days (up to five days).

-- Jun

Don_Modesto
04-21-2004, 02:43 PM
Hi Don,

Yup. Click on the "New Posts" link near the top.

There's also a drop-down for "Active Topics" which gives you the option of searching for active topics within the past X days (up to five days).

-- Jun

Very cool.

Often when away on weekends, I want just this "look back three days" feature.

Thanks, Jun.

DanielR
04-25-2004, 01:00 PM
Jun, is it possible that the "Active Forum Threads" column on the home page lists threads different from what one gets by accessing "Active Topics" -> "Last Day/ 2 Days/..." ?

PeaceHeather
04-25-2004, 08:48 PM
Hmm... I notice that I used to be able to track which folders I had read, because the red "new messages in this folder" icon would go away after I had looked at the new threads or messages.

Now that you've updated, that "refresh" seems to have gone away.

Heather

PS -- That's weird... now that I've posted something, the refresh seems to be behaving again. :freaky:

akiy
04-25-2004, 09:55 PM
Jun, is it possible that the "Active Forum Threads" column on the home page lists threads different from what one gets by accessing "Active Topics" -> "Last Day/ 2 Days/..." ?
It might. I believe there are some forums (like the feedback forum, for instance) which doesn't get displayed on the home page...

-- Jun

akiy
04-25-2004, 10:09 PM
Hi folks,

I noticed a bug in the Journals in using the new "buddy list" feature which has been fixed.

Also fixed is the automatic creation of a "poll discussion" thread.

Sorry for the inconvenience...

-- Jun

akiy
04-27-2004, 07:04 PM
Hi everyone,

Prompted by Chris Martin's note that he wasn't able to see the attachments, I delved into the problem, found, and fixed the problem. You should now be able to see and download attachments again.

Sorry for any troubles!

-- Jun

DanielR
07-23-2004, 02:59 PM
Hi Jun,

Unless I've missed that option, the "Search Forums" feature doesn't allow looking for an exact phrase (like when you google for "exact phrase", with the quotation marks). If that is indeed the case, I just thought it would be a useful thing to have, so maybe you would consider this for your "nice2have" list.

Best,

akiy
07-23-2004, 03:28 PM
Hi Daniel,

The latest version of the software (which I haven't gotten to installing yet due to an absolute lack of time) has a beta feature of using a different search mechanism. It would allow for searching for "booleans, wildcards, and phrase searching with a quoted phrase."

However, since that feature is still in beta, I'm going to have to do some testing on it... It may be a little while, but rest assured it's in the pipeline!

Thanks,

-- Jun